„JEŻELI” – przydatna funkcja w arkuszu kalkulacyjnym

05/05/2016Aktualizacja: 09/01/2020Excel Tutoriale Komentarze (192) Wrzuć na FB

Funkcja warunkowa JEŻELI ma szerokie zastosowanie. W niektórych sytuacjach jej znajomość może okazać się niezbędna. Jeśli musisz użyć formuły do rozwiązania jakiegoś zadania, a żadna ze znanych ci formuł nie jest skuteczna, to prawdopodobnie formuła JEŻELI będzie tą odpowiednią 🙂

Na końcu artykułu znajdziesz plik do pobrania z przykładowymi zadaniami.

Formułę JEŻELI można wielokrotnie zagnieżdżać. Maksymalnie można uzyskać aż 64 wyniki z jednej formuły. Dotyczy to oczywiście tych najnowszych wersji Microsoft Office Excel (w wersji Excel 97′ nie było aż tak dobrze). W tym tutorialu ograniczmy się do dwukrotnego wykorzystania funkcji JEŻELI w jednej formule.

W Excelu znajdziemy ją przechodząc do zakładki Formuły, następnie klikamy grupę „Logiczne” i z listy wybieramy JEŻELI. Pojawi się okienko:

 

Jak stosować funkcję JEŻELI

 

Jak to działa? Informacje podstawowe

Oczywiście funkcję możemy także wpisać ręcznie. Składnia tej funkcji jest następująca:

=JEŻELI(test_logiczny; wartość_jeżeli_prawda; wartość_jeżeli_fałsz)

Funkcja JEŻELI składa się z 3 argumentów. Trzeba pamiętać, że w każdej funkcji argumenty oddzielamy średnikiem.

Na czym polegają te argumenty?

Testem logicznym może być dowolny warunek, a także inna formuła. W drugim przypadku mamy do czynienia z formułą zagnieżdżoną.

Przykłady warunków:

A7>13
A7>=B7

A15<5
A15<=U7

A7<>25 (czyli A7 różne od 25)

A8*B8-D8<54
A5=”przykładowy tekst”

oraz(A1>9;A2<6)
lub(A5<>91;A5>=9)

Pamiętaj, że jeżeli w argumencie występuje tekst, to trzeba go ująć w cudzysłów. Nie możesz użyć tutaj podwójnych apostrofów. Musi to być 1 znak cudzysłowu.

Wartość „jeżeli prawda” to wartość zwracana jeżeli wynikiem testu logicznego jest prawda. Analogicznie – wartość „jeżeli fałsz” to wartość zwracana jeżeli wynikiem testu logicznego jest fałsz. Obie wartości mogą także być ciągami znaków (wyrazami), liczbami, jakimiś działaniami matematycznymi, a także różnymi formułami!

Przykładowy wygląd całej funkcji:

=JEŻELI(A1+B1<D1;”PRAWDA”;”FAŁSZ”)

Funkcja zagnieżdżona JEŻELI + ORAZ lub LUB

Możemy ubogacić i skomplikować warunek logiczny we funkcji JEŻELI używając funkcji ORAZ lub LUB. W klasycznym kształcie funkcja JEŻELI pozwala na 1 warunek logiczny (w 1. argumencie), np. A3 > 0 lub B6+M8 <> 87.

Jeżeli chcesz, żeby funkcja JEŻELI sprawdzała wiele warunków logicznych, czyli 2 lub więcej warunków, użyj funkcji ORAZ lub LUB.

Obie te funkcje mają taką samą strukturę. Argumenty tych funkcji to twoje warunki logiczne. Przykładowo, jeśli funkcja JEŻELI ma sprawdzać łącznie 2 warunki logiczne użyj funkcji ORAZ. Jeśli funkcja JEŻELI ma sprawdzać, czy chociaż 1 z warunków logicznych jest prawdziwy, użyj funkcję LUB.

Czym różnią się te formuły od siebie?

=JEŻELI(oraz(A1<B1;C1<D1);”JESTEŚ SUPER”,”ŚWIECI SŁOŃCE”);

=JEŻELI(lub(A1<B1;C1<D1);”JESTEŚ SUPER”,”ŚWIECI SŁOŃCE”);

Pierwsza formuła – aby funkcja JEŻELI zwróciła prawdę, czyli wyświetliła „JESTEŚ SUPER”, to muszą zostać spełnione jednocześnie oba warunki, które są argumentami funkcji ORAZ.

Druga formuła – aby funkcja JEŻELI zwróciła prawdę, czyli wyświetliła „JESTEŚ SUPER”, to musi zostać spełniony przynajmniej 1 warunek logiczny będący argumentem funkcji LUB.

Aby ułatwić sobie tworzenie formuł zagnieżdżonych i nie pogubić się w argumentach funkcji JEŻELI i w pilnowaniu nawiasów, polecam korzystać z narzędzia „Argumenty funkcji”.

 

Funkcja JEŻELI przydatnym narzędziem

 

Jak aktywować okienko „Argumenty funkcji?

  • Jeśli stosujesz sposób opisany na początku artykułu, czyli  idziemy do zakładki Formuły, a następnie klikamy w grupę „Logiczne” i z listy wybieramy funkcję JEŻELI, to do komórki zostanie wpisana pełna postać funkcji i jednocześnie uruchomi się okienko, o którym mowa.
  • Jeśli wpisujesz formułę ręcznie, to w dowolnym momencie możesz kliknąć w ikonę „Wstaw funkcję”, która niepozornie znajduje się obok paska formuły, a także na wstążce w zakładce Formuły.

Jak znaleźć ikonę „Wstaw funkcję”?

 

 

To zadanie znajduje się w pliku, który pobierzesz na końcu tego artykułu.

 

Funkcja zagnieżdżona JEŻELI + JEŻELI (część 1)

Przykład zainspirowany przykładem Irka, który poniżej w komentarz prosił o pomoc 🙂

W załączonym pliku na końcu artykułu znajdują się wszystkie omawiane przykłady.

W komórce A1 wpisujemy liczbę. Zależności od tego, jaką przybierze wartość chcemy wyświetlić 3 różne słowa. Używając formuły JEŻELI tylko raz – nie poradzimy sobie. Ale możemy użyć podwójnej funkcji JEŻELI w jednej formule.

kiedy A1<= 20 to wyświetl „gmina”

kiedy 20<A1<200 wyświetl „powiat”

kiedy A1>=200 wyświetl „województwo”

Oto moja propozycja rozwiązania (można to zrobić na kilka sposobów):

=JEŻELI(A1<=20;„gmina”;JEŻELI(A1>=200;”województwo”;”powiat”))

Jak to zrozumieć? Oto mój sposób rozumienia i radzenia sobie ze złożonymi formułami

1. Jeśli chcę użyć funkcji JEŻELI wewnątrz funkcji JEŻELI, jak w tym przykładzie, to zamieszczam ją na końcu formuły, w miejsce 3. argumentu. Generalnie można funkcję wewnętrzną JEŻELI wstawić gdziekolwiek, ale taki sposób po prostu najbardziej mi odpowiada.

2. Rysuję sobie oś liczbową, gdzie zaznaczam graniczne punkty. Myślę o tej formule w ten sposób, że będzie sprawdzać wszystkie warunki od lewej do prawej.

Niestandardowe zastosowanie funkcji JEŻELI

 

3. Moja funkcja ma rozpatrzyć 3 przypadki, więc na początku biorę pod uwagę 1. przypadek, czyli „gmina”.
Moja formuła ma póki co postać taką: =JEŻELI(A1<=20;”gmina”;

 

Niestandardowe zastosowanie funkcji JEŻELI

 

4. Zauważ, że liczby, które są powyżej zakreskowane, zostały już „obsłużone” przez formułę, ujęte już przez naszą formułę.

5. W 3. argumencie trzeba zatem „obsłużyć” przypadki liczbowe dla „powiatu i województwa”. W ostatnim argumencie zapominamy już o „gminie”. „Powiat” i „województwo” można tu zrobić przynajmniej na 2 sposoby. Trzeci argument został wyboldowany (wytłuszczony).

=JEŻELI(A1<=20;”gmina”;JEŻELI(A1>=200;”województwo”;”powiat”))

lub

=JEŻELI(A1<=20;”gmina”;JEŻELI(ORAZ(A1>20;A1<200);”powiat”;”województwo”))

Lepszy jest sposób pierwszy, gdyż jest krótszy 🙂 Ale jeśli chce zachować porządek „od lewej do prawej”, to musiałby się posiłkować dodatkową funkcją ORAZ, które musi tu zawierać 2 warunki.

To zadanie znajduje się w pliku, który pobierzesz na końcu tego artykułu.

 

Funkcja zagnieżdżona JEŻELI + JEŻELI (część 2)

 

Kolejne zadanie na zagnieżdżoną funkcję JEŻELI. Odwróćmy teraz sytuację. W komórce A1 będziemy wpisywać teraz jedno słowo: gmina, powiat lub województwo. W zależności od wybranego słowa, nasza funkcja JEŻELI będzie zwracać różne działania matematyczne.

kiedy A1 = „gmina”, to B1 * C1
kiedy A1 = „powiat”, to B1 + C1
kiedy A1 = „województwo”, to B1 / C1

Ostateczny kształt formuły jest następujący:

=JEŻELI(A1=”gmina”;B1*C1;JEŻELI(A1=”powiat”;B1+C1;B1/C1))

Jak widać, nie muszę rozpatrywać warunku dla „województwa”, gdyż przez wykluczenie zostało obsłużone w miejscu ostatniego argumentu: jeśli A1 nie jest „powiatem” to wykonaj działanie dla „województwa”.

We formule nie trzeba wpisywać A1=”gmina”. Zamiast „gmina” możesz wpisać adres komórki, gdzie już to słowo się znajduje. Tak też zrobiłem w pliku załączonym na końcu tego artykułu.

To zadanie znajduje się w pliku, który pobierzesz na końcu tego artykułu. Dla ułatwienia w komórce A1 zastosowałem listę (Dane > Poprawność danych).

Pomoc – Support

Pobierz tutaj plik XLSX z zadaniami omawianymi w tym artykule.

Jeśli potrzebujesz pomocy w stosowaniu formuły JEŻELI, opisz swój przykład w komentarzu poniżej. Jeśli chcesz zgłębić Excela skorzystaj z naszej oferty szkoleniowej.

SZKOLENIE MICROSOFT EXCEL ›

Dodaj komentarz

Dodając komentarz akceptujesz politykę prywatności (przeczytaj). Twój adres email nie zostanie opublikowany.
Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Komentarze

  • MAREK pisze:

    części do 5 zł = 15 zł
    części do 10 zł = 20 zł
    części do 20 z k = 40 zł
    do 30 zł = 50 zł
    do 40 ZŁ = 60 zł
    a powyżej 40 do 100 doliczyć 20 % doliczyć
    od 100 do 200 zł – doliczyć 10 %
    200 300 zł – doliczyć 5 %

  • Bart pisze:

    Czy w funkcji IF, warunkiem do spełnienia może być to, że tekst zawiera określoną lirerę lub cyfrę? Czy można wówczas użyć gwiazdek np *rz* aby dostać wyrazy z rz w środku, lub ?rz* aby otrzymać wyrazy z rz jako drugą głoskę?

  • Problem "Jeżeli" pisze:

    Dzień dobry,
    Mam tabelę, która zawiera 9 kolumn (od A do I). W kolumnie B zrobiłem pole wyboru (z listy rozwijanej wybieram: „K” lub „S”).
    Zależy mi, aby w kolumnie H wyliczało mi poprawną wartość, tzn. Jeżeli w kolumnie B wybiorę „K” to, w kolumnie H chciałbym mieć wynik kolumny F+G. Jeżeli wybiorę „S”, to chciałbym miec wynik F-G.

    Proszę o pomoc 😉